Resource Management Errors Affecting cinder package, versions <1:2013.1.3-0ubuntu2.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.63% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1304-CINDER-307857
  • published16 Sept 2013
  • disclosed16 Sept 2013

Introduced: 16 Sep 2013

CVE-2013-4202  (opens in a new tab)
CWE-399  (opens in a new tab)

How to fix?

Upgrade Ubuntu:13.04 cinder to version 1:2013.1.3-0ubuntu2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cinder package and not the cinder package as distributed by Ubuntu. See How to fix? for Ubuntu:13.04 relevant fixed versions and status.

The (1) backup (api/contrib/backups.py) and (2) volume transfer (contrib/volume_transfer.py) APIs in OpenStack Cinder Grizzly 2013.1.3 and earlier allows remote attackers to cause a denial of service (resource consumption and crash) via an XML Entity Expansion (XEE) attack. NOTE: this issue is due to an incomplete fix for CVE-2013-1664.

CVSS Base Scores

version 3.1