Numeric Errors Affecting cyrus-sasl2 package, versions <2.1.25.dfsg1-6ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.59% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1304-CYRUSSASL2-338960
  • published27 Oct 2013
  • disclosed27 Oct 2013

Introduced: 27 Oct 2013

CVE-2013-4122  (opens in a new tab)
CWE-189  (opens in a new tab)

How to fix?

Upgrade Ubuntu:13.04 cyrus-sasl2 to version 2.1.25.dfsg1-6ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cyrus-sasl2 package and not the cyrus-sasl2 package as distributed by Ubuntu. See How to fix? for Ubuntu:13.04 relevant fixed versions and status.

Cyrus SASL 2.1.23, 2.1.26, and earlier does not properly handle when a NULL value is returned upon an error by the crypt function as implemented in glibc 2.17 and later, which allows remote attackers to cause a denial of service (thread crash and consumption) via (1) an invalid salt or, when FIPS-140 is enabled, a (2) DES or (3) MD5 encrypted password, which triggers a NULL pointer dereference.

CVSS Base Scores

version 3.1