Improper Input Validation Affecting gnupg package, versions <1.4.12-7ubuntu1.2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
5.03% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1304-GNUPG-340554
  • published28 Oct 2013
  • disclosed28 Oct 2013

Introduced: 28 Oct 2013

CVE-2013-4402  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:13.04 gnupg to version 1.4.12-7ubuntu1.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnupg package and not the gnupg package as distributed by Ubuntu. See How to fix? for Ubuntu:13.04 relevant fixed versions and status.

The compressed packet parser in GnuPG 1.4.x before 1.4.15 and 2.0.x before 2.0.22 allows remote attackers to cause a denial of service (infinite recursion) via a crafted OpenPGP message.

CVSS Base Scores

version 3.1