Out-of-Bounds Affecting graphviz package, versions <2.26.3-14ubuntu1.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
6.08% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1304-GRAPHVIZ-294446
  • published10 Jan 2014
  • disclosed10 Jan 2014

Introduced: 10 Jan 2014

CVE-2014-1236  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:13.04 graphviz to version 2.26.3-14ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream graphviz package and not the graphviz package as distributed by Ubuntu. See How to fix? for Ubuntu:13.04 relevant fixed versions and status.

Stack-based buffer overflow in the chkNum function in lib/cgraph/scan.l in Graphviz 2.34.0 allows remote attackers to have unspecified impact via vectors related to a "badly formed number" and a "long digit list."

CVSS Base Scores

version 3.1