Improper Input Validation Affecting maas package, versions <1.3+bzr1461+dfsg-0ubuntu2.3


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.59% (44th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1304-MAAS-300556
  • published18 Nov 2013
  • disclosed18 Nov 2013

Introduced: 18 Nov 2013

CVE-2013-1057  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:13.04 maas to version 1.3+bzr1461+dfsg-0ubuntu2.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream maas package and not the maas package as distributed by Ubuntu. See How to fix? for Ubuntu:13.04 relevant fixed versions and status.

Untrusted search path vulnerability in maas-import-pxe-files in MAAS before 13.10 allows local users to execute arbitrary code via a Trojan horse import_pxe_files configuration file in the current working directory.

CVSS Base Scores

version 3.1