Resource Management Errors Affecting python2.7 package, versions <2.7.4-2ubuntu3.2


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.86% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1304-PYTHON27-306526
  • published9 Oct 2013
  • disclosed9 Oct 2013

Introduced: 9 Oct 2013

CVE-2013-2099  (opens in a new tab)
CWE-399  (opens in a new tab)

How to fix?

Upgrade Ubuntu:13.04 python2.7 to version 2.7.4-2ubuntu3.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python2.7 package and not the python2.7 package as distributed by Ubuntu. See How to fix? for Ubuntu:13.04 relevant fixed versions and status.

Algorithmic complexity vulnerability in the ssl.match_hostname function in Python 3.2.x, 3.3.x, and earlier, and unspecified versions of python-backports-ssl_match_hostname as used for older Python versions, allows remote attackers to cause a denial of service (CPU consumption) via multiple wildcard characters in the common name in a certificate.

CVSS Base Scores

version 3.1