Access Restriction Bypass Affecting ubuntu-system-service package, versions <0.2.4.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.36% (28th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1304-UBUNTUSYSTEMSERVICE-281992
  • published3 Oct 2013
  • disclosed3 Oct 2013

Introduced: 3 Oct 2013

CVE-2013-1062  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Ubuntu:13.04 ubuntu-system-service to version 0.2.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ubuntu-system-service package and not the ubuntu-system-service package as distributed by Ubuntu. See How to fix? for Ubuntu:13.04 relevant fixed versions and status.

ubuntu-system-service 0.2.4 before 0.2.4.1. 0.2.3 before 0.2.3.1, and 0.2.2 before 0.2.2.1 does not properly use D-Bus for communication with a polkit authority, which allows local users to bypass intended access restrictions by leveraging a PolkitUnixProcess PolkitSubject race condition via a (1) setuid process or (2) pkexec process, a related issue to CVE-2013-4288.

CVSS Base Scores

version 3.1