Improper Input Validation Affecting botan1.10 package, versions <1.10.5-1+deb7u1ubuntu0.14.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.36% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-BOTAN110-320537
  • published13 May 2016
  • disclosed13 May 2016

Introduced: 13 May 2016

CVE-2015-5726  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 botan1.10 to version 1.10.5-1+deb7u1ubuntu0.14.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream botan1.10 package and not the botan1.10 package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

The BER decoder in Botan 0.10.x before 1.10.10 and 1.11.x before 1.11.19 allows remote attackers to cause a denial of service (application crash) via an empty BIT STRING in ASN.1 data.