Improper Data Handling Affecting bsh package, versions <2.0b4-15ubuntu0.14.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
70.43% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-BSH-271136
  • published7 Apr 2016
  • disclosed7 Apr 2016

Introduced: 7 Apr 2016

CVE-2016-2510  (opens in a new tab)
CWE-19  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 bsh to version 2.0b4-15ubuntu0.14.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream bsh package and not the bsh package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

BeanShell (bsh) before 2.0b6, when included on the classpath by an application that uses Java serialization or XStream, allows remote attackers to execute arbitrary code via crafted serialized data, related to XThis.Handler.

CVSS Base Scores

version 3.1