Improper Input Validation Affecting cakephp package, versions <1.3.15-1+deb7u2build0.14.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
5.15% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-CAKEPHP-340165
  • published23 Jan 2017
  • disclosed23 Jan 2017

Introduced: 23 Jan 2017

CVE-2016-4793  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 cakephp to version 1.3.15-1+deb7u2build0.14.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cakephp package and not the cakephp package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their IP via the CLIENT-IP HTTP header.