CVE-2015-1853 Affecting chrony package, versions <1.29-1ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.7% (75th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-CHRONY-277697
  • published27 Jun 2018
  • disclosed9 Dec 2019

Introduced: 27 Jun 2018

CVE-2015-1853  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 chrony to version 1.29-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream chrony package and not the chrony package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

chrony before 1.31.1 does not properly protect state variables in authenticated symmetric NTP associations, which allows remote attackers with knowledge of NTP peering to cause a denial of service (inability to synchronize) via random timestamps in crafted NTP data packets.

CVSS Base Scores

version 3.1