Code Affecting chrony package, versions <1.29-1ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.94% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-CHRONY-277738
  • published16 Apr 2015
  • disclosed16 Apr 2015

Introduced: 16 Apr 2015

CVE-2015-1822  (opens in a new tab)
CWE-17  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 chrony to version 1.29-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream chrony package and not the chrony package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

chrony before 1.31.1 does not initialize the last "next" pointer when saving unacknowledged replies to command requests, which allows remote authenticated users to cause a denial of service (uninitialized pointer dereference and daemon crash) or possibly execute arbitrary code via a large number of command requests.

CVSS Base Scores

version 3.1