Improper Input Validation Affecting cordova-ubuntu package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
8.94% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-CORDOVAUBUNTU-273122
  • published3 Mar 2014
  • disclosed3 Mar 2014

Introduced: 3 Mar 2014

CVE-2012-6637  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:14.04 cordova-ubuntu.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cordova-ubuntu package and not the cordova-ubuntu package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Apache Cordova 3.3.0 and earlier and Adobe PhoneGap 2.9.0 and earlier do not anchor the end of domain-name regular expressions, which allows remote attackers to bypass a whitelist protection mechanism via a domain name that contains an acceptable name as an initial substring.

CVSS Base Scores

version 3.1