Cross-site Scripting (XSS) Affecting cups package, versions <1.7.2-0ubuntu1.6


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
7.25% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-CUPS-364375
  • published26 Jun 2015
  • disclosed26 Jun 2015

Introduced: 26 Jun 2015

CVE-2015-1159  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 cups to version 1.7.2-0ubuntu1.6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cups package and not the cups package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Cross-site scripting (XSS) vulnerability in the cgi_puts function in cgi-bin/template.c in the template engine in CUPS before 2.0.3 allows remote attackers to inject arbitrary web script or HTML via the QUERY parameter to help/.

CVSS Base Scores

version 3.1