Security Features Affecting cups package, versions <1.7.2-0ubuntu1.6


Severity

Recommended
high

Based on Ubuntu security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
29.73% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-CUPS-364396
  • published26 Jun 2015
  • disclosed26 Jun 2015

Introduced: 26 Jun 2015

CVE-2015-1158  (opens in a new tab)
CWE-254  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 cups to version 1.7.2-0ubuntu1.6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cups package and not the cups package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

The add_job function in scheduler/ipp.c in cupsd in CUPS before 2.0.3 performs incorrect free operations for multiple-value job-originating-host-name attributes, which allows remote attackers to trigger data corruption for reference-counted strings via a crafted (1) IPP_CREATE_JOB or (2) IPP_PRINT_JOB request, as demonstrated by replacing the configuration file and consequently executing arbitrary code.

CVSS Base Scores

version 3.1