Access Restriction Bypass Affecting cups package, versions <1.7.2-0ubuntu1.2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.91% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-CUPS-364404
  • published29 Jul 2014
  • disclosed29 Jul 2014

Introduced: 29 Jul 2014

CVE-2014-5031  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 cups to version 1.7.2-0ubuntu1.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cups package and not the cups package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

The web interface in CUPS before 2.0 does not check that files have world-readable permissions, which allows remote attackers to obtains sensitive information via unspecified vectors.

CVSS Base Scores

version 3.1