Cross-site Scripting (XSS) Affecting cups package, versions <1.7.2-0ubuntu1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.63% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-CUPS-364454
  • published18 Apr 2014
  • disclosed18 Apr 2014

Introduced: 18 Apr 2014

CVE-2014-2856  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 cups to version 1.7.2-0ubuntu1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cups package and not the cups package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Cross-site scripting (XSS) vulnerability in scheduler/client.c in Common Unix Printing System (CUPS) before 1.7.2 allows remote attackers to inject arbitrary web script or HTML via the URL path, related to the is_path_absolute function.

CVSS Base Scores

version 3.1