Numeric Errors Affecting dosfstools package, versions <3.0.26-1ubuntu0.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.42% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-DOSFSTOOLS-320259
  • published3 Jun 2016
  • disclosed3 Jun 2016

Introduced: 3 Jun 2016

CVE-2015-8872  (opens in a new tab)
CWE-189  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 dosfstools to version 3.0.26-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dosfstools package and not the dosfstools package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

The set_fat function in fat.c in dosfstools before 4.0 might allow attackers to corrupt a FAT12 filesystem or cause a denial of service (invalid memory read and crash) by writing an odd number of clusters to the third to last entry on a FAT12 filesystem, which triggers an "off-by-two error."

CVSS Base Scores

version 3.1