Directory Traversal Affecting dpkg package, versions <1.17.5ubuntu5.3


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.83% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-DPKG-336505
  • published30 May 2014
  • disclosed30 May 2014

Introduced: 30 May 2014

CVE-2014-3864  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 dpkg to version 1.17.5ubuntu5.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dpkg package and not the dpkg package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Directory traversal vulnerability in dpkg-source in dpkg-dev 1.3.0 allows remote attackers to modify files outside of the intended directories via a crafted source package that lacks a --- header line.

CVSS Base Scores

version 3.1