Cross-site Scripting (XSS) Affecting fckeditor package, versions *


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.51% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-FCKEDITOR-265723
  • published11 Jun 2014
  • disclosed11 Jun 2014

Introduced: 11 Jun 2014

CVE-2014-4037  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:14.04 fckeditor.

NVD Description

Note: Versions mentioned in the description apply only to the upstream fckeditor package and not the fckeditor package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Cross-site scripting (XSS) vulnerability in editor/dialog/fck_spellerpages/spellerpages/server-scripts/spellchecker.php in FCKeditor before 2.6.11 and earlier allows remote attackers to inject arbitrary web script or HTML via an array key in the textinputs[] parameter, a different issue than CVE-2012-4000.

CVSS Base Scores

version 3.1