Missing Authorization Affecting firebird2.5 package, versions <2.5.2.26540.ds4-9ubuntu1.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.3% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-FIREBIRD25-282393
  • published24 Mar 2017
  • disclosed24 Mar 2017

Introduced: 24 Mar 2017

CVE-2017-6369  (opens in a new tab)
CWE-862  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 firebird2.5 to version 2.5.2.26540.ds4-9ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream firebird2.5 package and not the firebird2.5 package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Insufficient checks in the UDF subsystem in Firebird 2.5.x before 2.5.7 and 3.0.x before 3.0.2 allow remote authenticated users to execute code by using a 'system' entrypoint from fbudf.so.

CVSS Base Scores

version 3.1