Numeric Errors Affecting freeimage package, versions <3.15.4-3ubuntu0.1+esm1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.03% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-FREEIMAGE-321178
  • published29 Sept 2015
  • disclosed29 Sept 2015

Introduced: 29 Sep 2015

CVE-2015-0852  (opens in a new tab)
CWE-189  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 freeimage to version 3.15.4-3ubuntu0.1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream freeimage package and not the freeimage package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Multiple integer underflows in PluginPCX.cpp in FreeImage 3.17.0 and earlier allow remote attackers to cause a denial of service (heap memory corruption) via vectors related to the height and width of a window.

CVSS Base Scores

version 3.1