Access Restriction Bypass Affecting glance package, versions <1:2014.1.4-0ubuntu1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.79% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-GLANCE-313242
  • published7 Jan 2015
  • disclosed7 Jan 2015

Introduced: 7 Jan 2015

CVE-2014-9493  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 glance to version 1:2014.1.4-0ubuntu1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream glance package and not the glance package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

The V2 API in OpenStack Image Registry and Delivery Service (Glance) before 2014.2.2 and 2014.1.4 allows remote authenticated users to read or delete arbitrary files via a full pathname in a file: URL in the image location property.

CVSS Base Scores

version 3.1