Access Restriction Bypass Affecting glance package, versions <1:2014.1.2-0ubuntu1.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.15% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-GLANCE-313247
  • published25 Aug 2014
  • disclosed25 Aug 2014

Introduced: 25 Aug 2014

CVE-2014-5356  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 glance to version 1:2014.1.2-0ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream glance package and not the glance package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

OpenStack Image Registry and Delivery Service (Glance) before 2013.2.4, 2014.x before 2014.1.3, and Juno before Juno-3, when using the V2 API, does not properly enforce the image_size_cap configuration option, which allows remote authenticated users to cause a denial of service (disk consumption) by uploading a large image.

CVSS Base Scores

version 3.1