Directory Traversal Affecting glance package, versions <1:2014.1.4-0ubuntu1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.79% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-GLANCE-313321
  • published21 Jan 2015
  • disclosed21 Jan 2015

Introduced: 21 Jan 2015

CVE-2015-1195  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 glance to version 1:2014.1.4-0ubuntu1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream glance package and not the glance package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

The V2 API in OpenStack Image Registry and Delivery Service (Glance) before 2014.1.4 and 2014.2.x before 2014.2.2 allows remote authenticated users to read or delete arbitrary files via a full pathname in a filesystem: URL in the image location property. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-9493.

CVSS Base Scores

version 3.1