Insufficiently Protected Credentials Affecting gnome-keyring package, versions <3.10.1-1ubuntu4.4


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.54% (75th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-GNOMEKEYRING-338078
  • published12 Feb 2019
  • disclosed12 Feb 2019

Introduced: 12 Feb 2019

CVE-2018-20781  (opens in a new tab)
CWE-522  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 gnome-keyring to version 3.10.1-1ubuntu4.4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnome-keyring package and not the gnome-keyring package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

In pam/gkr-pam-module.c in GNOME Keyring before 3.27.2, the user's password is kept in a session-child process spawned from the LightDM daemon. This can expose the credential in cleartext.

CVSS Base Scores

version 3.1