Out-of-bounds Read Affecting gst-plugins-bad0.10 package, versions <0.10.23-7.2ubuntu1.3+esm1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.91% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-GSTPLUGINSBAD010-386032
  • published13 Jan 2017
  • disclosed13 Jan 2017

Introduced: 13 Jan 2017

CVE-2016-9809  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 gst-plugins-bad0.10 to version 0.10.23-7.2ubuntu1.3+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gst-plugins-bad0.10 package and not the gst-plugins-bad0.10 package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Off-by-one error in the gst_h264_parse_set_caps function in GStreamer before 1.10.2 allows remote attackers to have unspecified impact via a crafted file, which triggers an out-of-bounds read.