Out-of-bounds Read Affecting gst-plugins-ugly0.10 package, versions <0.10.19-2+deb7u1ubuntu0.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.63% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-GSTPLUGINSUGLY010-276192
  • published9 Feb 2017
  • disclosed9 Feb 2017

Introduced: 9 Feb 2017

CVE-2017-5847  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 gst-plugins-ugly0.10 to version 0.10.19-2+deb7u1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gst-plugins-ugly0.10 package and not the gst-plugins-ugly0.10 package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

The gst_asf_demux_process_ext_content_desc function in gst/asfdemux/gstasfdemux.c in gst-plugins-ugly in GStreamer allows remote attackers to cause a denial of service (out-of-bounds heap read) via vectors involving extended content descriptors.

CVSS Base Scores

version 3.1