Out-of-Bounds Affecting hdf5 package, versions <1.8.11-5ubuntu7.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.61% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-HDF5-370602
  • published18 Nov 2016
  • disclosed18 Nov 2016

Introduced: 18 Nov 2016

CVE-2016-4333  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 hdf5 to version 1.8.11-5ubuntu7.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hdf5 package and not the hdf5 package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

The HDF5 1.8.16 library allocating space for the array using a value from the file has an impact within the loop for initializing said array allowing a value within the file to modify the loop's terminator. Due to this, an aggressor can cause the loop's index to point outside the bounds of the array when initializing it.