Out-of-Bounds Affecting hdf5 package, versions <1.8.11-5ubuntu7.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.8% (56th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-HDF5-370608
  • published18 Nov 2016
  • disclosed18 Nov 2016

Introduced: 18 Nov 2016

CVE-2016-4330  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 hdf5 to version 1.8.11-5ubuntu7.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hdf5 package and not the hdf5 package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

In the HDF5 1.8.16 library's failure to check if the number of dimensions for an array read from the file is within the bounds of the space allocated for it, a heap-based buffer overflow will occur, potentially leading to arbitrary code execution.