Cross-site Scripting (XSS) Affecting horizon package, versions <1:2014.1.2-0ubuntu1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.24% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-HORIZON-330157
  • published31 Oct 2014
  • disclosed31 Oct 2014

Introduced: 31 Oct 2014

CVE-2014-3475  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 horizon to version 1:2014.1.2-0ubuntu1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream horizon package and not the horizon package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Cross-site scripting (XSS) vulnerability in the Users panel (admin/users/) in OpenStack Dashboard (Horizon) before 2013.2.4, 2014.1 before 2014.1.2, and Juno before Juno-2 allows remote administrators to inject arbitrary web script or HTML via a user email address, a different vulnerability than CVE-2014-8578.

CVSS Base Scores

version 3.1