Use After Free Affecting irssi package, versions <0.8.15-5ubuntu3.3


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.08% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-IRSSI-350716
  • published22 Oct 2017
  • disclosed22 Oct 2017

Introduced: 22 Oct 2017

CVE-2017-15227  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 irssi to version 0.8.15-5ubuntu3.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream irssi package and not the irssi package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Irssi before 1.0.5, while waiting for the channel synchronisation, may incorrectly fail to remove destroyed channels from the query list, resulting in use-after-free conditions when updating the state later on.