Integer Overflow or Wraparound Affecting jbig2dec package, versions <0.11+20120125-1ubuntu1.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.18% (67th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-JBIG2DEC-308482
  • published17 Apr 2017
  • disclosed17 Apr 2017

Introduced: 17 Apr 2017

CVE-2017-7885  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 jbig2dec to version 0.11+20120125-1ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream jbig2dec package and not the jbig2dec package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Artifex jbig2dec 0.13 has a heap-based buffer over-read leading to denial of service (application crash) or disclosure of sensitive information from process memory, because of an integer overflow in the jbig2_decode_symbol_dict function in jbig2_symbol_dict.c in libjbig2dec.a during operation on a crafted .jb2 file.