CVE-2019-10906 Affecting jinja2 package, versions <2.7.2-2ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.53% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-JINJA2-342831
  • published7 Apr 2019
  • disclosed7 Apr 2019

Introduced: 7 Apr 2019

CVE-2019-10906  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 jinja2 to version 2.7.2-2ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream jinja2 package and not the jinja2 package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

In Pallets Jinja before 2.10.1, str.format_map allows a sandbox escape.

References

CVSS Base Scores

version 3.1