Out-of-bounds Read Affecting libcrypto++ package, versions <5.6.1-6+deb8u3ubuntu0.1~esm1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.72% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-LIBCRYPTO-293600
  • published5 Jun 2017
  • disclosed5 Jun 2017

Introduced: 5 Jun 2017

CVE-2017-9434  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 libcrypto++ to version 5.6.1-6+deb8u3ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcrypto++ package and not the libcrypto++ package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Crypto++ (aka cryptopp) through 5.6.5 contains an out-of-bounds read vulnerability in zinflate.cpp in the Inflator filter.