Information Exposure Affecting libcrypto++ package, versions <5.6.1-6+deb8u1build0.14.04.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.86% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-LIBCRYPTO-293606
  • published1 Jul 2015
  • disclosed1 Jul 2015

Introduced: 1 Jul 2015

CVE-2015-2141  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 libcrypto++ to version 5.6.1-6+deb8u1build0.14.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcrypto++ package and not the libcrypto++ package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

The InvertibleRWFunction::CalculateInverse function in rw.cpp in libcrypt++ 5.6.2 does not properly blind private key operations for the Rabin-Williams digital signature algorithm, which allows remote attackers to obtain private keys via a timing attack.

CVSS Base Scores

version 3.1