Out-of-Bounds Affecting libdbi-perl package, versions <1.630-1ubuntu0.1~esm4


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.74% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-LIBDBIPERL-674544
  • published15 Sept 2020
  • disclosed11 Sept 2020

Introduced: 11 Sep 2020

CVE-2013-7490  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 libdbi-perl to version 1.630-1ubuntu0.1~esm4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libdbi-perl package and not the libdbi-perl package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

An issue was discovered in the DBI module before 1.632 for Perl. Using many arguments to methods for Callbacks may lead to memory corruption.

CVSS Base Scores

version 3.1