Improper Access Control Affecting libmodule-signature-perl package, versions <0.73-1ubuntu0.14.04.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.34% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-LIBMODULESIGNATUREPERL-306048
  • published19 May 2015
  • disclosed19 May 2015

Introduced: 19 May 2015

CVE-2015-3407  (opens in a new tab)
CWE-284  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 libmodule-signature-perl to version 0.73-1ubuntu0.14.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libmodule-signature-perl package and not the libmodule-signature-perl package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Module::Signature before 0.74 allows remote attackers to bypass signature verification for files via a signature file that does not list the files.

CVSS Base Scores

version 3.1