Numeric Errors Affecting libraw package, versions <0.15.4-1ubuntu0.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
5.44% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-LIBRAW-323714
  • published19 May 2015
  • disclosed19 May 2015

Introduced: 19 May 2015

CVE-2015-3885  (opens in a new tab)
CWE-189  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 libraw to version 0.15.4-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libraw package and not the libraw package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Integer overflow in the ljpeg_start function in dcraw 7.00 and earlier allows remote attackers to cause a denial of service (crash) via a crafted image, which triggers a buffer overflow, related to the len variable.

CVSS Base Scores

version 3.1