Incorrect Calculation Affecting libreoffice package, versions <1:4.2.8-0ubuntu5.5


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.03% (63rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-LIBREOFFICE-341813
  • published29 Jan 2019
  • disclosed31 Jan 2019

Introduced: 29 Jan 2019

CVE-2018-11790  (opens in a new tab)
CWE-682  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 libreoffice to version 1:4.2.8-0ubuntu5.5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libreoffice package and not the libreoffice package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

When loading a document with Apache Open Office 4.1.5 and earlier with smaller end line termination than the operating system uses, the defect occurs. In this case OpenOffice runs into an Arithmetic Overflow at a string length calculation.