Out-of-bounds Read Affecting libsdl2 package, versions <2.0.2+dfsg1-3ubuntu1.3+esm1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.92% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-LIBSDL2-337235
  • published7 Feb 2019
  • disclosed7 Feb 2019

Introduced: 7 Feb 2019

CVE-2019-7578  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 libsdl2 to version 2.0.2+dfsg1-3ubuntu1.3+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsdl2 package and not the libsdl2 package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

SDL (Simple DirectMedia Layer) through 1.2.15 and 2.x through 2.0.9 has a heap-based buffer over-read in InitIMA_ADPCM in audio/SDL_wave.c.

CVSS Base Scores

version 3.1