Out-of-Bounds Affecting libsdl2-image package, versions <2.0.0+dfsg-3+deb8u1build0.14.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.53% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-LIBSDL2IMAGE-338669
  • published24 Apr 2018
  • disclosed24 Apr 2018

Introduced: 24 Apr 2018

CVE-2017-14450  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 libsdl2-image to version 2.0.0+dfsg-3+deb8u1build0.14.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsdl2-image package and not the libsdl2-image package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

A buffer overflow vulnerability exists in the GIF image parsing functionality of SDL2_image-2.0.2. A specially crafted GIF image can lead to a buffer overflow on a global section. An attacker can display an image to trigger this vulnerability.