Out-of-bounds Write Affecting libsdl2-image package, versions <2.0.0+dfsg-3+deb8u2build0.14.04.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.48% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-LIBSDL2IMAGE-345346
  • published2 Dec 2018
  • disclosed1 Nov 2018

Introduced: 1 Nov 2018

CVE-2018-3977  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 libsdl2-image to version 2.0.0+dfsg-3+deb8u2build0.14.04.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsdl2-image package and not the libsdl2-image package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

An exploitable code execution vulnerability exists in the XCF image rendering functionality of SDL2_image-2.0.3. A specially crafted XCF image can cause a heap overflow, resulting in code execution. An attacker can display a specially crafted image to trigger this vulnerability.