Improper Input Validation Affecting libvpx package, versions <1.3.0-2ubuntu0.1~esm1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.81% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-LIBVPX-342575
  • published12 Jan 2018
  • disclosed12 Jan 2018

Introduced: 12 Jan 2018

CVE-2017-13194  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 libvpx to version 1.3.0-2ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libvpx package and not the libvpx package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

A vulnerability in the Android media framework (libvpx) related to odd frame width. Product: Android. Versions: 7.0, 7.1.1, 7.1.2, 8.0, 8.1. Android ID: A-64710201.