Out-of-bounds Read Affecting libxfont package, versions <1:1.4.7-1ubuntu0.3


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.4% (34th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-LIBXFONT-313117
  • published11 Oct 2017
  • disclosed11 Oct 2017

Introduced: 11 Oct 2017

CVE-2017-13722  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 libxfont to version 1:1.4.7-1ubuntu0.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxfont package and not the libxfont package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

In the pcfGetProperties function in bitmap/pcfread.c in libXfont through 1.5.2 and 2.x before 2.0.2, a missing boundary check (for PCF files) could be used by local attackers authenticated to an Xserver for a buffer over-read, for information disclosure or a crash of the X server.