Use After Free Affecting libxkbcommon package, versions <0.4.1-0ubuntu1.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.45% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-LIBXKBCOMMON-263425
  • published25 Sept 2018
  • disclosed25 Aug 2018

Introduced: 25 Aug 2018

CVE-2018-15857  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 libxkbcommon to version 0.4.1-0ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxkbcommon package and not the libxkbcommon package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

An invalid free in ExprAppendMultiKeysymList in xkbcomp/ast-build.c in xkbcommon before 0.8.1 could be used by local attackers to crash xkbcommon keymap parsers or possibly have unspecified other impact by supplying a crafted keymap file.