Arbitrary Code Injection The advisory has been revoked - it doesn't affect any version of package libxstream-java  (opens in a new tab)


Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
77.23% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-LIBXSTREAMJAVA-1612263
  • published9 Feb 2022
  • disclosed28 May 2021

Introduced: 28 May 2021

CVE-2021-29505  (opens in a new tab)
CWE-94  (opens in a new tab)
CWE-502  (opens in a new tab)

Amendment

The Ubuntu security team deemed this advisory irrelevant for Ubuntu:14.04.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxstream-java package and not the libxstream-java package as distributed by Ubuntu.

XStream is software for serializing Java objects to XML and back again. A vulnerability in XStream versions prior to 1.4.17 may allow a remote attacker has sufficient rights to execute commands of the host only by manipulating the processed input stream. No user who followed the recommendation to setup XStream's security framework with a whitelist limited to the minimal required types is affected. The vulnerability is patched in version 1.4.17.

References