Information Exposure Affecting mapserver package, versions <6.4.1-2ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.5% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-MAPSERVER-281448
  • published8 Dec 2016
  • disclosed8 Dec 2016

Introduced: 8 Dec 2016

CVE-2016-9839  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 mapserver to version 6.4.1-2ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mapserver package and not the mapserver package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

In MapServer before 7.0.3, OGR driver error messages are too verbose and may leak sensitive information if data connection fails.

CVSS Base Scores

version 3.1