Cross-site Scripting (XSS) Affecting monit package, versions <1:5.6-2ubuntu0.1+esm2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.41% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-MONIT-346453
  • published22 Apr 2019
  • disclosed22 Apr 2019

Introduced: 22 Apr 2019

CVE-2019-11454  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 monit to version 1:5.6-2ubuntu0.1+esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream monit package and not the monit package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

Persistent cross-site scripting (XSS) in http/cervlet.c in Tildeslash Monit before 5.25.3 allows a remote unauthenticated attacker to introduce arbitrary JavaScript via manipulation of an unsanitized user field of the Authorization header for HTTP Basic Authentication, which is mishandled during an _viewlog operation.

CVSS Base Scores

version 3.1