Out-of-bounds Write Affecting musl package, versions <0.9.15-1ubuntu0.1~esm2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.53% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1404-MUSL-1638322
  • published10 Sept 2020
  • disclosed6 Aug 2019

Introduced: 6 Aug 2019

CVE-2019-14697  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:14.04 musl to version 0.9.15-1ubuntu0.1~esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream musl package and not the musl package as distributed by Ubuntu. See How to fix? for Ubuntu:14.04 relevant fixed versions and status.

musl libc through 1.1.23 has an x87 floating-point stack adjustment imbalance, related to the math/i386/ directory. In some cases, use of this library could introduce out-of-bounds writes that are not present in an application's source code.

CVSS Base Scores

version 3.1